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Introduction to Embarcaderoôs Rapid SQL  

Rapid SQL® is an integrated development environment that enables developers to create, edit, 

version, tune, and deploy server-side objects residing on Microsoft® SQL Server, Oracle®, Sybase 

Adaptive Server®, IBM® UDB DB2®, and IBM® DB2® for OS/390® databases. Its unified database 

development environment provides extensive graphical facilities that simplify SQL scripting, object 

management, reverse engineering, database project management, version control and schema 

deployment. With Rapid SQL, programmers can develop and maintain high-quality, high-performance 

client/server and web-based applications in less time, and with greater accuracy. 

Product Benefits by Audience 

Database Developers/Administrators  

Rapid SQL provides an easy-to-use graphical user interface (GUI), which allows Database 

Developers to be immediately productive in a cross-platform environment without having 

platform specific knowledge.  Along this line, Rapid SQL provides standard object creation 

wizards and graphical object editors for all supported platforms, which greatly reduce the 

time and effort to build an application database from the ground up.   

Rapid SQL also offers several cross-platform code-generation options, which help 

Developers build SQL code that is syntactically and functionally correct the first time.  In 

addition, Rapid SQL can be used for the immediate or scheduled execution of SQL scripts 

and files, both with output and notification options. 

Rapid SQL makes short order of working with data by providing Developers with several easy-

to-use browsing, visual query building and data editing options.  All operations can be 

completed with drag-and-drop, point-and-click ease, with little or no SQL coding required.    

Database Project Management 

Rapid SQL provides seamless, out-of-the-box integration with all major Version Control 

Systems (VCS).  Rapid SQL offers complete database project management capabilities, 

which allows for the reverse-engineering of live database objects into corresponding off-

line SQL source code files, which may be checked into and out of any of the supported VCSs.  

Rapid SQL also provides detailed HTML reports at the database object level that can be 

viewed immediately within the application or published to a defined web directory. 
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About this Evaluation Guide 

This evaluation guide is intended to help you get started using Embarcaderoôs Rapid SQL. 

After completion of this evaluation guide, youôll have the foundation you need to explore the many 

features of Rapid SQL.  Youôll have learned how to register and connect cross-platform datasources, 

navigate the database explorer, work with the individual object browsers, editors and wizards, build 

and manage projects, and leverage many of the productivity-focused features offered throughout 

Rapid SQL. You will also know that Rapid SQL allows you to concentrate more on what needs to be 

done and less on how it should be done. 

This guide is divided into separate sessions. Do them all at once, or complete them individually as you 

have time: 

 

 Session 1: Getting Started with Rapid SQL 

 Session 2: Productivity Enhancers 

 Session 3: Scripting 

 Session 4: Working with Code Workbench 

 Session 5: Building a Database Project 

 Section 6: Visual Query Builder and Data Editor 

 Section 7: Code Analyst 

 Section 8: SQL Debugging and Profiling 

 

You can use this basic tutorial as a roadmap of product highlights; but also to help you find your own 

path to explore Rapid SQL.  

 

 
 

Once youôve started, you can 

select Help Topics from the 

Help menu to find many 

additional resources 

including Tutorials that 

complement and build on 

many of the activities shown 

in this brief guide.  
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Session 1: Getting Started with Rapid SQL 

Download and Install 

You can obtain the latest version of the Rapid SQL software from the Embarcadero website at 

www.embarcadero.com.   

Click ñDownloadò, and follow the steps indicated. Save the file on your computer and then double-

click to launch the self-extracting file that will guide you through the installation process.  

When you first install an evaluation copy of Rapid SQL, you can use the tool for 14 days. After that 

time, a permanent license is needed.  

Overview 

The graphic below illustrates all the elements of the Rapid SQL application window. 

 

Database Explorer     Datasource Group      Datasource      Toolbars      Application Workspace    

 

 

 

Explorer Tab      Favorites Tab      Project Tab        

http://www.embarcadero.com/
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Start Rapid SQL 

1. Choose Start > Programs>Embarcadero Rapid SQL 7.6.0>Rapid SQL 7.6.0. 

The first time Rapid SQL starts, if offers to automatically discover and register any datasources 
on your network.  The Discover Datasources feature automatically searches the DBMS 
configuration files and discovers datasources residing on your system that are not currently 
registered. When you use this feature, a dialog box lists the name of the server or instance and 
the type of DBMS of all unregistered datasources found on your network or local machine and 
gives you the option to register the discovered datasources.   

2. Choose ñNoò for the purpose of this guide.   

Registering Cross-Platform Datasources 

For now, you will register a data source manually. 

1. On the Datasource menu, select Register Datasource.  A Datasource Registration wizard 
opens. 

 

2. Choose Microsoft SQL Server as the DBMS type and then click Next. 

Rapid SQL allows you to view and manage all of your databases at the same time from the 

Database Explorer.  You can easily move from DB2 to Oracle to SQL Server to Sybase all within the 

same window.   Rapid SQLôs multi-threaded, productivity-enhancing environment allows you to have 

several workspaces open at the same time so you can continue to work, even while the application 

processes in the background.  
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3. Specify the Host name of a SQL Server datasource on your network, override the Datasource 

name with ñSAMPLE_DATASOURCEò and then click Next. 

4. Provide valid credentials in the User ID and Password boxes, and then select the Auto-

Connect? checkbox to eliminate having to provide credentials each time you connect to this 

datasource. 

5. In the left-hand pane, select Datasource Group, select the MS SQL Server folder, and then click 

Finish.  

6. Select Yes when prompted to connect to the new datasource. 

Rapid SQL offers the same easy-to-use Datasource Registration Wizard for IBM DB2, Microsoft SQL 
Server, Oracle, Sybase and ODBC connections.  The connection information only needs to be set up 
one time for each platform and can be saved locally or in a common datasource catalog for use by 
other Embarcadero products. 

You can configure Embarcadero database applications to use a datasource catalog stored in the 

system registry of your machine (local) or to use a datasource catalog located in the registry of 

another computer (remote). This capability makes it easy to share datasource catalogs among multiple 

users so that maintenance can occur in one location.  

All Embarcadero database management products share the datasource catalog, which means that 

when you set up your datasource catalog using one product such as Rapid SQL, the same list of 

datasources is available in other Embarcadero Technologies products. Any changes you make to the 

datasource catalog are reflected in all Embarcadero database management products. 
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Session 2: Productivity Enhancers 

Database Object Management Made Easy 

Rapid SQL makes it easy and intuitive to navigate between datasources and to drill-down into atomic 

database objects within the Database Explorer Tree.  The Database Explorer Tree displays all 

registered datasources and serves as the entry-point for much of Rapid SQLôs advanced functionality.  

The Database Explorer Tree 

1. Click on the Explorer title bar and select By Object Type. 

 

2. Select and Expand the SAMPLE_DATASOURCE > Databases > pubs node to display the 
database object sub-nodes. 

 

 

 

 

Creating an Object Using the Object Creation Wizard 

From within the Database Explorer Tree you can create any database object using simple Object 

Creation Wizards.  The following is an example of how to use the Table Object Creation Wizard.  It is 

similar to the object creation wizards available within Rapid SQL for all database objects.  

1. Right-click on the Tables node and select New.  A Create Table Wizard opens. 
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2. Select a Schema, provide a Name of SAMPLE_TABLE.  Leave the remaining default settings 

and click Next. 

3. Add a column, using a Name of Sample_Column1 and select a Type of char(100).  
Experiment with the Add Column and Delete buttons, and with selecting a column and 
modifying its attributes.    

4. Click Finish.  The DDL View panel opens showing the DDL that will be used to create the 
new table. 

 

5. Deselect the Launch Object Editor After Execute and then click Execute. 

 

Rapid SQL builds the platform-specific SQL code, syntactically-correct and ready to run the first time.  

There is no SQL coding required in any of the Rapid SQL creation wizards. 

Working With an Existing Object Using the Object Editor 
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While the wizard offered you the option to automatically open an editor on creating the table, you can 

also manually open an editor.  

1. In the Database Explorer, right-click on your new table and select Open. 

 

 

Object editor features are as follows: 

 All Object Editors provide standardized, multi-tabbed windows for each database object type. 

 All Object Editors provide fully-functional toolbars for easy object management 

 Rapid SQL has full knowledge of the underlying DBMS system catalog, syntax and alteration 

rules, so the user can concentrate on what needs to be done, not how to do it. 

 Drop-down boxes allow you to easily move between owners and objects. 

The Rapid SQL Object Editor easily performs operations that would normally require painstaking and 

error-prone scripting, such as deleting or inserting columns in a table while preserving data, 

dependencies and permissions. Rapid SQL analyzes the database catalog to determine its structure, 

and then automatically generates the SQL script required for the extended alteration.  For instance, 

when a full table alteration is required, Rapid SQL automatically unloads and reloads the data, 

eliminating tedious work. 

Close the object editor window. 

Object Documentation and Reporting 

Rapid SQL provides rich, detailed HTML Reporting for all database objects.  Building a browser-ready 

report for any object is any a few mouse-clicks away. 

1. Expand the Tables node, right-click on any table and select Report from the menu. A Report 
dialog opens. 
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2. Enter a destination Report Home Page File Name.  This can be a network web server 
directory\file.   

3. Enter a Report Title and click Execute. 

The HTML report will automatically be displayed in the Rapid SQL application workspace.  For 
example: 

 

The HTML report can be saved to a new file or referenced in the file named above. 

NOTE: All HTML reports are browser-ready and suitable for posting directly to the web. 

 

Working With Code, Files and Data 

Rapid SQL provides many features and powerful development tools for creating and executing SQL 

code and working with data. 

 

 

 

Setting Environment Options 

The Options Editor allows you to set the Rapid SQL development environment to meet your needs.  

1. Select File > Options from the menu.  The Options dialog opens. 

Note:  For purposes of this Evaluation Guide, we are only covering high-level functionality of the 

major features and tools within Rapid SQL.  
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The Options dialog has one page per option category.  You select an option category in the left-hand 

pane and can subsequently set options on that page.  Options are applied when you click OK. 

 

Favorites Tab 

The Favorites Tab provides a drag-and-drop library interface of all supported DBMS syntax, SQL 

syntax, built-in functions, optimizer hints, and SQL-conditional syntax. Additionally, it provides the 

ability to create custom folders to store commonly-used code for quick and efficient access, as 

needed. 

To open the Favorites Explorer: 

1. At the bottom of the Explorer pane, click Favorites. The Favorites Explorer appears. 

2. Expand the Microsoft node and then expend the Schema subnode. 

3. RIght-click the Procedures node and select Open. The selected code opens in the SQL Editor 

window and is ready for execution. 

To add a custom folder to the Favorites Explorer 

1. Open the Favorites Explorer and right-click the Favorites folder. 

2. Select New Folder from the menu. A new folder is added to the bottom of the tree view. 

To add an existing script to the Favorites Tab 

1. Select New>SQL, create a two or three-line script in the SQL editor, and then save your script. 

2. After saving the script, right-click anywhere on the workspace and select Add to Favorites. The 

Favorite Properties dialog box opens. 

3. Enter the appropriate information in the fields provided. The script is added to the Favorites 

Explorer. 
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NOTE: Code from the Paste SQL, Paste SQL Syntax, and Favorites Tab are available from any 

SQL or DDL Editing window. 

Working with Scripts and Files 

Rapid SQL extends the auto-generation of SQL code by allowing you to run your scripts across 

multiple databases at the same time.  In addition, there is the option to execute the code immediately 

or schedule it to run later via the Windows NT Event Scheduler or the Embarcadero Job Scheduler. 

 

Script Execution Facility 

1. On the Favorites Explorer, navigate to the Microsoft SQL Server node and select the Schema 

subnode. 

2. Right-click the Procedures node and select Script Execution Facility. The Script Execution 

Facility dialog box appears. 

 

3. Click the Target Tab and select the datasources against which the script will run. 

4. Click the Output Tab and select a type of output format. For the purposes of this example, select 

Graphical Output. 

5. If you want to send a notification message indicating that the script has executed, click the Notify 

Tab and enter the appropriate information in the fields provided. 

6. Click Execute. Rapid SQL runs the script against the datasources specified on the Target Tab. 

NOTE: Separate script output windows are created for each selected datasource. 

 

File Execution Facility 

Similar to the Script Execution Facility, files containing SQL scripts can be added to the File Execution 

Facility and executed immediately or scheduled to run later.  Other than the origin of the code, all 

supporting functionality is the same.  

1. On the Tools toolbar, click File Execution Facility.  Rapid SQL opens the File Execution Facility 

dialog box. 

2. To locate the file you want to execute, click Add. Use the Select Files dialog box to locate and 

select a file. 
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3. On the Target Tab, select the datasources to run the script against. 

4. On the Output Tab, select the desired output option. For the purposes of this example, select 

Graphical Output. 

5. To enable the scheduling function for the script, you must select the File Output option. 

6. If you want to send notification that the script has executed, on the Notify Tab, complete the 

target information. 

7. Click Execute.  

Rapid SQL runs the script against the target datasources. 

NOTE: Separate script output windows are created for each selected datasource. 

 

Viewing Data 

Rapid SQL provides several options for browsing data.  In addition, it gives you the ability to construct 

even the most complex SQL statements with point-and-click ease. 

 

Select * Browsing 

1. On the Database Explorer ensure that the Explorer tab is displayed and then expand the MS 

SQL server node.  

2. Expand any database you know has table data, expand the Tables node, right-click a table, and 

then click SELECT * FROM.  

All columns and rows from the table are displayed in the active workspace. 

 

Retaining Datasoure Explorer View Settings 

1. Click on expandable settings at the top of the Explorer pane. 

 

2. Select Retain View Settings. 

The Explorer will open the next time just as you left it.  All connections that were present when you 
closed DBArtisan will be re-established.  
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Datasource Explorer Bookmarks 

Rapid SQL allows you to set bookmarks for frequently visited database objects. 

1. Right-click on any node in the Datasource Explorer Tree. 

 

2. Select ñAdd Bookmarkò. 

You may wish to modify the bookmark name. 

After Bookmarks are defined you can use them to easily navigate to commonly used datasource 

resources via the main menu ñBookmarksò item.       

 

The Bookmark Manager handles maintenance of Bookmarks. 

1. Select Bookmarks from the menu bar. 

2. Select Bookmark Manager. 
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Setting Keyboard Shortcuts and Hotkeys 

1. On the Tools menu, select Customize. 

 

2. In the Customize dialog go to the Keyboard tab. 

3. The Keyboard tab can be used to set Keyboard shortcut hotkeys for all areas of DBArtisan 
functionality.   

 

Referencing Most Recently Used Datasources 

1. Select File > Recent Datasources and then select a datasource.   
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This will automatically place you on the datasource within the Explorer, ready to work with active 

connection.  
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Session 3: Scripting 

Generating Code 

By providing several code generation and assistance options, Rapid SQL makes cross-platform 

development easy for developers of all experience levels.  

 

 

 

 

 

Code Generation Facility 

The Code Generation Facility can be used to create complete procedures, functions or packages 

revolving around views or tables. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Finished! 

 

Note:  The following examples build on the SQL Server 2000 SAMPLE_DATASOURCE 

registered earlier in this Evaluation Guide.  These examples can be applied to any registered 

datasource for any of the supported platforms.   

1. From the menu, open Tools > Code 
Generation Facility. 

2. Select the SAMPLE_DATASOURCE 
datasource and the ñpubsò database 
from the drop-down listboxes. 

3. Select the ñauthorsò table, ñstateò as 
the input column and all columns for 
output. 

4. Select ñselectò as the code option. 

5. Select a file to save the generated 
script and check ñOpenò. 

6. Click ñOKò and the DDL to create the 
procedure will be generated and 
displayed in an editable window, called 
the DDL Editor.  You can edit the name 
of the new procedure and any of the 
generated code at this time.  Name the 
new procedure 
ñsample_select_authorsò. 

7. Click on the  (execute or step 
execute) button to submit the DDL and 
create the procedure. 

8. The indicated file will be saved on the 
selected directory. 

 

 

9.  

10.  

No SQL statement coding is required to 

generate complete stored procedures and 

packages.  If applicable, Rapid SQL allows all 

generated code to be previewed and edited to fit 

any development need.  
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Right-click feature 

Similar to the Code Generation Facility, the ñright-clickò code generation feature can be used to create 

complete procedures, functions or packages revolving around views or tables. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

1. From the Database Explorer Tree, expand the 
SAMPLE_DATASOURCE > pubs > Tables sub 
node. 

2. Right-click on the ñauthorsò table. 

3. Select Generate > Procedure > Select. 

4. Select ñstateò as the input column, and leave all 
output columns selected. 

5. Click ñOKò and the DDL to create the procedure will 
be generated and displayed in an editable window, 
called the DDL Editor.  You can edit the name of the 
new procedure and any of the generated code.  
Name the new procedure ñsample_select_authorsò. 

6. Click on the  (execute or step execute) button 
to submit the DDL and create the procedure. 

Finished! 

 

 

No SQL statement coding is required to generate 

complete stored procedures and packages.  If 

applicable, Rapid SQL allows all generated code to be 

previewed and edited to fit any development need. 




